Back to overview
Downtime

Knowt Services Down

Jun 13 at 09:24am HDT
Affected services
Overall
AP Exams

Resolved
Jun 13 at 11:56am HDT

We have identified the AWS outage and have verified that it has been resolved. Knowt onwards!

Created
Jun 13 at 09:24am HDT

Due to an outage with Amazon Web Services, Knowt's servers are currently down.

We believe that the problems in site service are related to a failure in AWS, as mentioned at https://health.aws.amazon.com/health/status